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A simple guide to processing LIDAR data in 
QGIS  
 
 
Why write another guide?  Aren’t there enough out there already? 
I’ve written this because all the guides that I’ve come across are based upon earlier versions 
of QGIS.  Version 3 saw big changes in the software and while some things remained the 
same there are significant differences.   
 
Background 
There are two stages to producing a LIDAR map of your chosen location.  The first is to 
download the data from the Environment Agency website.  To view the LIDAR data (which 
at this stage is just numbers in a database) you will need to import it into mapping software.  
This guide shows you how to process LIDAR data using QGIS mapping software, available 
for free on the internet. 
 
This guide is based on the Mac version of QGIS 3.10 A Coruna.  Window versions are 
similar.  There might be slight differences in the menus.  QGIS is regularly updated and there 
might be new versions by the time you read this guide (produced in early 2023).    
 
 
 
SECTION ONE - HOW TO DOWNLOAD LIDAR DATA 
 
Environment Agency LIDAR can be downloaded for free here:  
https://environment.data.gov.uk/DefraDataDownload/?Mode=survey 
 
 Clicking on the above opens a map of the UK. Type in the place name you want in the 
‘Choose location or tile’ box in the top left of the screen.  This will zoom you into a map 
view.  
To select an area, click on the funny square symbol (with small squares at each corner) in the 
right-hand menu that is titled ‘Download your data’.   
This allows you to draw a square around the area you want to download.  Don’t worry about 
being too precise because whatever you draw you will get all the data inside the full 
Ordnance Survey square (known as a tile).  For example, the tile that covers the centre of 
Wheathampstead is TL11 SE. 
 
Once you have made your selection the screen reformats itself and the area is shown in a 
yellow box.  Click on Available tiles in the right menu box.  You will get a list of all the 
LIDAR data that is held for this tile. In the case of the Wheathampstead example one of the 
available tiles are:  LIDAR-DTM-50CM-2019-TL11se. 
 
What does this mean?   
Let’s take a short pause while we learn about the different types of LIDAR data. 
You are likely to find a combination of three available file types and three different 
resolutions: 
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DTM (Digital Terrain Map) and DEM (Digital Elevation Map) are confusingly the same 
thing – vegetation and trees are stripped out and the surface is revealed underneath – this is 
the most useful version for archaeologists 
DSM (Digital Surface Map) – the survey stops at the top of tree and vegetation.  This is not 
so useful even although LIDAR surveys are usually done in the winter. 
Composite combining DTM and DSM. 
Resolution: LIDAR data comes in different image resolutions.  The highest resolution is 
50cm and this is the best for archaeological interpretation.  The other common survey 
resolutions are one metre and two metres. 
 
The menu allows you to browse through Product (i.e.  DTM or DSM), Year (when the survey 
took place) and Resolution (50cm, one or two metres).  Incidentally, there might be limited or 
no coverage in some places.  Note that only a limited number of areas have been surveyed at 
50cm. 
 
If you have been using my example you should have LIDAR-DTM-50CM-2019-TL11se in the 
‘Available tiles’.  If you haven’t got this file on your screen this is probably because the data 
has been updated.  To use my example click on the ‘resolution’ menu and choose ‘50cm’.  
Choose 2019 in the Year menu and the file should appear.  This is a 50cm Digital Terrain 
Mode survey done in 2019 and this is the best quality resolution. 
 
Click on the file name and your chosen LIDAR file should appear in the download in the top 
right of the screen. 
 
Congratulations!  You’ve now got your data but you can’t read it until you put it into QGIS 
mapping software.  The next step is to download QGIS.   
 
 
 
 
SECTION TWO – DOWNLOAD QGIS MAPPING SOFTWARE 
 
LIDAR data is a database of digital height information.  In order to view LIDAR it needs to 
be imported into geographical information service software for producing maps.  QGIS is a 
free GIS software that is widely used by academic and students. It can be downloaded here: 
https://www.qgis.org/en/site/forusers/download.html 
Follow the instructions and download the app. 
 
 
 
 
SECTION THREE – PROCESSING THE LIDAR DATA WITH 
QGIS 
 
Opening a new project in QGIS 
Open QGIS.   
In the Project menu at the top click on New.    
Scroll down to the Coordinate Reference System icon on the bottom right of the screen (next 
to the three dots).  This will take you into the ‘Project Properties/ CRS’ menu.  Select OSGB 
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1936/ British National Grid EPSG:27700.  Click Apply and OK.  This ensures that whatever 
you drop into your map will conform to the same mapping protocol. 
 
Unzipping the data 
Now go back to the LIDAR data that you downloaded from the Environment Agency 
website.  This data will have been downloaded as a ZIP folder.  This is a compressed file 
format.  Click on the folder.  This will create a second uncompressed folder with the same 
title but without the ‘zip’ suffix.  
 
The next bit is really important for your sanity. Create a new folder with the project title 
you intend using.  In my case this would be ‘Wheathampstead 50cm 2019’.  Place the 
unzipped folder with your LIDAR files into this folder.    
 
Why is this so important? 
The reason is that when you save a QGIS project you are not saving the data files that 
created it.      
For a saved project to re-open it needs to find a path to the data files that created it.  If you 
move the data folder or rename it this will not happen and you will have effectively lost your 
project.   
So, to avoid disaster I always create a project folder and place the unzipped LIDAR data 
folder into it before I open a new QGIS project.  I’m getting ahead of myself but after I’ve 
created the new project file I save it into the same folder as the LIDAR data folder to ensure 
they can always find each other.   
 
Importing the data file 
You are now ready to drop the unzipped LIDAR data files into your new project.  Simply 
pull the data files from the folder and dump them in the white centre of the QGIS screen.  
They should automatically transfer themselves into the Layer panel on the left (and if the 
Layer panel isn’t visible go into the View menu and scroll down to Panels).  
  
Once the data files are in the Layers panel you should see a hazy and unfocused image appear 
on the main screen.  In the case of my Wheathampstead example it probably looks 
disconcertingly like coiled-up intestines.  What you are looking at is unprocessed LIDAR 
data of a river valley.  To make sense of it you need to apply Hillshade.   
 
Applying hillshade 
Hillshade is what turns the coiled-up intestines of raw LIDAR into something useful. 
 
To apply hillshade, select a layer and do a right-click.  
 This opens a drop-down menu.  
Click on Properties at the bottom and open the Symbology menu.  
Change Render type to Hillshade.   
Chose a suitable lighting azimuth (i.e. the direction the light is coming from).  This is the 
most powerful tool in Hillshade because with the wrong light direction a feature might not 
appear at all.  So, a bit of experimentation with the azimuth setting may be necessary. 
It is also possible to set multi-directional hillshade but I’m not going to deal with this here. 
 
Select a Z factor of 6 to increases the contrast. (It doesn’t matter if this is too high or low 
because you can change all your selections in Hillshade after the event). 
Ignore the Colour Rendering options. 
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Click on Apply and then OK.  Admire the hillshade. 
 
Merging layers.  Is it a good idea? 
The bad news is that my example has eight layers and you will need to apply hillshade to 
each one.  Can you merge layers together and just apply hillshade to the top merged layer?  
Indeed, you can. 
 
Don’t do it!   
There is a good reason to avoid merged layers.  Merged layers are temporary scratch files and 
they cannot be saved when you close your project.  When you reopen your project the 
original layers will still be there but your merged layer (and your hillshade) will have 
vanished. 
 
Excellent!  So why did you bother telling me about a merged layer?   The answer is that 
working with merged multiple tiles could be a useful way of experimenting with hillshade 
and other settings.  After finding the best setting you can apply it to each individual tile and 
delete the merge file.   This way the project will reopen with your data intact. 
   
I’m kind of convinced so how do I do a merged layer?   
Click on the Raster menu.  Go to miscellaneous and click on merge.   
This opens the Merge box.  Click on the three dots at the end of Input layers.   
This will open the Multiple selection menu and a list of the layers.  Tick the layers you want 
to merge and press OK.  The box will disappear and be replaced by the Merge menu that will 
display the number of layers selected in the Input layers box.   
BEWARE!  On my Mac screen the merge menu opens at the back of the main QGIS screen 
where I can’t see it!  So, if it doesn’t appear start looking for it on your desktop.   
Once you’ve located the menu click run and a merge layer will appear on the Layers panel.    
 
Missing bits on the map 
At this stage in the demo you should be looking at a beautiful hill-shaded map.  But what 
about the bit of the map that are missing? Did something go wrong?  The sad fact is that there 
are gaps in the Environment Agency LIDAR surveys.  This is particularly the case in the 
50cm surveys my example is based upon.  You might have better luck choosing either a one 
or two metre survey. 
    
Adding a ‘proper’ map to help you navigate 
The easiest map to add is OpenStreetMap in the browser panel (in the View menu next to 
Layers).  It’s probably best to avoid Google Maps because it is difficult/ impossible to 
remove labels advertising local businesses etc.  But this might not matter if you are using the 
extra mapping for navigation purposes rather than incorporating it as part of your map. 
 
Incidentally, you can also add maps and resources off the internet including those provided 
by the Dept. of the Environment, Ordnance Survey (and this includes topographical maps 
featuring contour layers) and also georeferenced maps off the National Library of Scotland 
collection that covers all of the UK.  (Also see ‘Loading NLS maps’ in the ‘Other useful 
stuff’ section). 
 
Applying contours 
The LIDAR data can be used to create contours that can be very useful when trying to make 
sense of a landscape.  This is how to do it: 
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Go to the Raster menu and scroll down to Extract.  This opens the Contour menu.  I change 
the Interval between contour lines to 6.000000.  Press Run and the contours will appear.  The 
colour of the contour lines will be selected at random so you will probably want to change 
them. 
   
The colour and size of the line can be changed by right clicking on the Contour layer and 
selecting Properties and then Symbology.  Personally, I select red line in the symbol menu 
box underneath Favorites.    I also change the Width option to 0.46000.  
Press Apply. 
 
You can also add contours using a downloaded Ordnance Survey topography map.  The 
important difference is that OS contours derive from a traditional OS survey whereas the 
contours within QGIS derive from your LIDAR height data.  One advantage of the OS 
topographical map is that it can be saved in the project file and easily switched on and off.  
 
 
Exporting maps 
When you’ve finished your project, how do you print it or send a copy to colleagues? 
The easiest way is via export to create a jpeg or tif. 
 
This is how you do it:  
In the ‘Project’ menu select ‘layout’ and ‘export as image’ and select the preferred file 
format.  TIF is best because it’s lossless and can be turned into Photoshop files but a JPEG is 
a good compromise that will open on any computer..   I also select ‘Resolution’ and pick 
either 600 or 1200 tpi to produce a large file.  I’m not sure if there is a better way of doing 
this but it seems to work for me. 
I open TIF files in Adobe Photoshop and do any corrections such as contrast or clarity to 
make the LIDAR image easier to study.   
I usually save and distribute the finished result as a JPEG. 
 
What about sending a colleague my original project file so they can work on it? 
You will need to send them the project file folder that contains both the saved project file and 
the data files that created them.   Otherwise, the file will not open. 
 
Problems with saving projects 
It is worth repeating the point that I made earlier that a project will not reopen if it cannot 
find the files that created it.  So always create a new project folder before you start work and 
place the data file folder into it.  Save the new project into the same folder so that it’s sitting 
next to the data file folder that created it and you should have no problems. 
 
Don’t forget that temporary scratch files will not save (although I suspect there may be ways 
of doing this that I have not found).   Temporary scratch files include such things as merged 
layers and contours.  If you attempt to save a project with temporary scratch files you will get 
this message (or similar): 
 
“This project includes one or more temporary layers. These layers are not permanently saved 
and their contents will be lost. Are you sure you want to proceed?” 
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Whenever I see this message it reminds me that it would have been a good idea to delete the 
temporary layers before I started to save the project.  Because I’m lazy I usually say ‘yes’ and 
close the project down. 
 
The only problem with this pragmatic approach is that when you try and reopen the project 
file this will trigger the Handle unavailable layer menu.  This is because the temporary files 
are still there (even though they cannot be opened).   Highlight Remove unavailable layer.  
This will produce yet another menu like this: 
 
“There are still unhandled layer(s). If they are not fixed, they will be disabled/deactivated 
until the project is opened again.”  
 
Press OK and the project file should open.  Remind yourself that you could have avoided all 
this palaver by deleting any temporary layers which you were going to lose anyway.  
 
Help! White screen problems when reopening a project. 
If your project reopens with the layers intact but a white screen where your map should be, 
go to Zoom full in the View menu.   
 
 
 
 
 
 
 
Other useful stuff 
 
Simple relief map 
This option flattens large relief features like hills in favour of emphasising lump and bumps.  
Highlight the layer you want to turn into an SRM and select Raster menu.  Choose the Relief 
Visualisation Toolbox.  (Note - If you cannot find this option, go to the Plug-in menu and 
select Manage and instal plug-ins.  Search through the list in the menu and instal Relief 
Visualisation Toolkit.)  
 
Clicking on the Relief Visualisation Toolkit will open a menu with a number of options.  
Select the file you want to turn into a SRM.  Click on the Simple Local Relief Model  and 
press Start.  After the SRM is created apply hillshade.  Try multidirectional hillshade.  
 
 
Loading NLS maps 
You can download geo-referenced Ordnance Survey maps from the national Livbrary of 
Scotland collection.  Go to the NLS site and find the location of the map you need on the 
georeferenced map section. 
Click on Overlay on the bottom menu.  This opens a location menu.  Select the county you 
want to add to your QGIS project. A new menu will open.  Select Desktop and then XYZ in 
the menu above.  This open a https link which you need to copy.  Below is the https address 
link for the 19th century Hertfordshire 25” Ordnance Survey map.  
 
https://mapseries-tilesets.s3.amazonaws.com/25_inch/hertfordshire/{z}/{x}/{y}.png  
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Open your QGIS project and select the browser menu (left hand side at the bottom).  Right 
click on ZYZ tiles and select XYZ connection.  Type in a name for the tile. I named it 25 inch 
OS.  Paste the https address link and press OK.  This should load the tile into you XYZ tile 
menu in browser with the name you selected.  Click on it and it will appear in the Layers 
menu. 
 
Mike Smith 
December 2023 
 


